Elevated Latency

Incident Report for Netlify

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 18:05 UTC

Monitoring

We have released a fix and are monitoring this issue.
Posted Mar 12, 2025 - 16:35 UTC

Update

We are continuing to investigate this issue.
Posted Mar 12, 2025 - 16:19 UTC

Investigating

We are currently experiencing elevated latency to our API and app
Posted Mar 12, 2025 - 16:13 UTC
This incident affected: Netlify Application UI and API.