Increased latency with the Visual Editor and Create API

Incident Report for Netlify

Resolved

This issue has been resolved.
Posted Mar 10, 2025 - 16:50 UTC

Monitoring

A fix has been implemented and we're currently monitoring the results.
Posted Mar 10, 2025 - 16:26 UTC

Update

We are continuing to investigate this issue.
Posted Mar 10, 2025 - 15:47 UTC

Investigating

We are currently investigating increased latency with the Visual Editor and Create API.
Posted Mar 10, 2025 - 15:45 UTC
This incident affected: Netlify Create API and Visual Editor.