Inconsistent Caching for Sites on HP Edge Network

Incident Report for Netlify

Resolved

A fix has been deployed. We continue to monitor the system for any issues.
Posted Feb 19, 2025 - 01:03 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 18, 2025 - 16:28 UTC

Update

We've deployed improvements to address caching inconsistencies and are rolling out fixes to affected customers. Monitoring continues
Posted Feb 18, 2025 - 15:12 UTC

Update

We have implemented a more comprehensive fix for the caching issues and are rolling the HP Edge customers into it. We have narrowed down the root cause and are working on addressing it
Posted Feb 18, 2025 - 14:35 UTC

Monitoring

We are continuing to monitor to ensure this issue is mitigated while we work on identifying and implementing a fix for the root cause.
Posted Feb 16, 2025 - 23:40 UTC

Update

We are actively monitoring to ensure this issue is mitigated while we work on identifying and implementing a fix for the root cause.
Posted Feb 16, 2025 - 23:32 UTC

Update

We have implemented a solution to mitigate this issue across our CDN. We are continuing to investigate the root cause.
Posted Feb 16, 2025 - 23:03 UTC

Identified

We've identified caching inconsistencies with several sites across our HP Edge Network. We are implementing a fix to resolve this issue.
Posted Feb 16, 2025 - 22:47 UTC
This incident affected: High-Performance Edge Network and Standard Edge Network.