Connect domain certifications have expired

Incident Report for Netlify

Resolved

Between 15:13 UTC and 16:05 UTC, Connect experienced an issue due to an expired domain certificate. The issue has been fully resolved, and services are operating normally.
Posted Jan 29, 2025 - 16:17 UTC

Identified

The issue has been identified and a fix has been implemented.
Posted Jan 29, 2025 - 16:02 UTC

Update

Our team is actively working to resolve the issue.
Posted Jan 29, 2025 - 15:53 UTC

Investigating

Connect domain certificates have expired, affecting origin requests to the Connect API and accessing the Connect dashboard in the Netlify app.
Posted Jan 29, 2025 - 15:34 UTC
This incident affected: Netlify Connect.